What’s Vulnerable › Vulnerabilities

CVE-2018-18311

Description

Perl before 5.26.3 and 5.28.x before 5.28.1 has a buffer overflow via a crafted regular expression that triggers invalid write operations.

Affected products

How to fix

Upgrade to a fixed version: macOS 10.14.4; McAfee Web Gateway (MWG) 7.7.2.21, 7.8.2.8, 8.1.1; perl 5.26.3, 5.28.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2018-18311 or the next vulnerability affects your stack