What’s Vulnerable › Vulnerabilities
CVE-2018-18313
- Severity: critical (CVSS 9.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 9.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-12-07 · updated 2026-06-17
- Weakness: CWE-125
Description
Perl before 5.26.3 has a buffer over-read via a crafted regular expression that triggers disclosure of sensitive information from process memory.
Affected products
- macOS: before 10.14.4 — fixed in 10.14.4
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04, 18.04, 18.10
- Debian Linux: 9.0
- E-Series SANtricity OS Controller Software 11.x: from 11.0 through 11.40
- NetApp Snap Creator Framework: all versions
- NetApp SnapCenter: all versions
- NetApp Snapdrive: all versions
- perl: before 5.26.3 — fixed in 5.26.3
- Red Hat Enterprise Linux: 6.0, 7.0, 7.4, 7.5, 7.6
How to fix
Upgrade to a fixed version: macOS 10.14.4; perl 5.26.3. Check the vendor advisory for mitigations.
References
- http://seclists.org/fulldisclosure/2019/Mar/49
- http://www.securitytracker.com/id/1042181
- https://access.redhat.com/errata/RHSA-2019:0001
- https://access.redhat.com/errata/RHSA-2019:0010
- https://bugzilla.redhat.com/show_bug.cgi?id=1646738
- https://github.com/Perl/perl5/commit/43b2f4ef399e2fd7240b4eeb0658686ad95f8e62
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/RWQGEB543QN7SSBRKYJM6PSOC3RLYGSM/
- https://metacpan.org/changes/release/SHAY/perl-5.26.3
- https://rt.perl.org/Ticket/Display.html?id=133192
- https://seclists.org/bugtraq/2019/Mar/42
- https://security.gentoo.org/glsa/201909-01
- https://security.netapp.com/advisory/ntap-20190221-0003/
Get alerted when CVE-2018-18313 or the next vulnerability affects your stack