What’s Vulnerable › Vulnerabilities
CVE-2018-18314
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-12-07 · updated 2026-06-17
- Weakness: CWE-119
Description
Perl before 5.26.3 has a buffer overflow via a crafted regular expression that triggers invalid write operations.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04, 18.10
- Debian Linux: 9.0
- E-Series SANtricity OS Controller Software 11.x: from 11.0 through 11.40
- NetApp Snap Creator Framework: all versions
- NetApp SnapCenter: all versions
- NetApp Snapdrive: all versions
- perl: before 5.26.3 — fixed in 5.26.3
- Red Hat Enterprise Linux: 6.0, 7.0, 7.4, 7.5, 7.6
How to fix
Upgrade to a fixed version: perl 5.26.3. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/106145
- http://www.securitytracker.com/id/1042181
- https://access.redhat.com/errata/RHSA-2019:0001
- https://access.redhat.com/errata/RHSA-2019:0010
- https://bugzilla.redhat.com/show_bug.cgi?id=1646751
- https://github.com/Perl/perl5/commit/19a498a461d7c81ae3507c450953d1148efecf4f
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/RWQGEB543QN7SSBRKYJM6PSOC3RLYGSM/
- https://metacpan.org/changes/release/SHAY/perl-5.26.3
- https://rt.perl.org/Ticket/Display.html?id=131649
- https://security.gentoo.org/glsa/201909-01
- https://security.netapp.com/advisory/ntap-20190221-0003/
- https://usn.ubuntu.com/3834-1/
Get alerted when CVE-2018-18314 or the next vulnerability affects your stack