What’s Vulnerable › Vulnerabilities
CVE-2018-18325: DotNetNuke (DNN) Inadequate Encryption Strength Vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2021-11-03
- EPSS: 74.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-07-03 · updated 2026-06-17
- Weakness: CWE-326
Description
DNN (aka DotNetNuke) 9.2 through 9.2.2 uses a weak encryption algorithm to protect input parameters. NOTE: this issue exists because of an incomplete fix for CVE-2018-15811.
Affected products
- DotNetNuke CMS Fixed in 9.1.1: from 9.2 through 9.2.2
References
- http://packetstormsecurity.com/files/157080/DotNetNuke-Cookie-Deserialization-Remote-Code-Execution.html
- https://github.com/dnnsoftware/Dnn.Platform/releases
- https://www.dnnsoftware.com/community/security/security-center
- http://packetstormsecurity.com/files/157080/DotNetNuke-Cookie-Deserialization-Remote-Code-Execution.html
- https://github.com/dnnsoftware/Dnn.Platform/releases
- https://www.dnnsoftware.com/community/security/security-center
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2018-18325
Get alerted when CVE-2018-18325 or the next vulnerability affects your stack