What’s Vulnerable › Vulnerabilities
CVE-2018-18356
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-12-11 · updated 2026-06-17
- Weakness: CWE-190
Description
An integer overflow in path handling lead to a use after free in Skia in Google Chrome prior to 71.0.3578.80 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04, 18.10
- Debian Linux: 8.0, 9.0
- Google Chrome: before 71.0.3578.80 — fixed in 71.0.3578.80
- openSUSE Leap: 15.0
- RedHat Enterprise Linux Desktop: 6.0, 7.0
- RedHat Enterprise Linux Server: 6.0, 7.0
- RedHat Enterprise Linux Server Aus: 7.6
- RedHat Enterprise Linux Server Eus: 7.6
- RedHat Enterprise Linux Server Tus: 7.6
- RedHat Enterprise Linux Workstation: 6.0, 7.0
How to fix
Upgrade to a fixed version: Google Chrome 71.0.3578.80. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00043.html
- http://www.securityfocus.com/bid/106084
- https://access.redhat.com/errata/RHSA-2018:3803
- https://access.redhat.com/errata/RHSA-2019:0373
- https://access.redhat.com/errata/RHSA-2019:0374
- https://access.redhat.com/errata/RHSA-2019:1144
- https://chromereleases.googleblog.com/2018/12/stable-channel-update-for-desktop.html
- https://crbug.com/883666
- https://lists.debian.org/debian-lts-announce/2019/02/msg00023.html
- https://lists.debian.org/debian-lts-announce/2019/02/msg00024.html
- https://security.gentoo.org/glsa/201903-04
- https://security.gentoo.org/glsa/201904-07
Get alerted when CVE-2018-18356 or the next vulnerability affects your stack