What’s Vulnerable › Vulnerabilities
CVE-2018-18385
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-10-16 · updated 2026-06-17
- Weakness: CWE-835
Description
Asciidoctor in versions < 1.5.8 allows remote attackers to cause a denial of service (infinite loop). The loop was caused by the fact that Parser.next_block was not exhausting all the lines in the reader as the while loop expected it would. This was happening because the regular expression that detects any list was not agreeing with the regular expression that detects a specific list type. So the line kept getting pushed back onto the reader, hence causing the loop.
Affected products
- Asciidoctor: before 1.5.8 — fixed in 1.5.8
How to fix
Upgrade to a fixed version: Asciidoctor 1.5.8. Check the vendor advisory for mitigations.
References
- https://github.com/asciidoctor/asciidoctor/issues/2888
- https://github.com/asciidoctor/asciidoctor/issues/2888
Get alerted when CVE-2018-18385 or the next vulnerability affects your stack