What’s Vulnerable › Vulnerabilities
CVE-2018-18386
- Severity: low (CVSS 3.3 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-10-17 · updated 2026-06-17
- Weakness: CWE-704
Description
drivers/tty/n_tty.c in the Linux kernel before 4.14.11 allows local attackers (who are able to access pseudo terminals) to hang/block further usage of any pseudo terminal devices due to an EXTPROC versus ICANON confusion in TIOCINQ.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04
- Linux kernel: before 4.14.11 — fixed in 4.14.11
How to fix
Upgrade to a fixed version: Linux kernel 4.14.11. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=966031f340185eddd05affcf72b740549f056348
- https://access.redhat.com/errata/RHSA-2019:0831
- https://bugzilla.suse.com/show_bug.cgi?id=1094825
- https://cdn.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.14.11
- https://github.com/torvalds/linux/commit/966031f340185eddd05affcf72b740549f056348
- https://usn.ubuntu.com/3849-1/
- https://usn.ubuntu.com/3849-2/
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=966031f340185eddd05affcf72b740549f056348
- https://access.redhat.com/errata/RHSA-2019:0831
- https://bugzilla.suse.com/show_bug.cgi?id=1094825
- https://cdn.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.14.11
- https://github.com/torvalds/linux/commit/966031f340185eddd05affcf72b740549f056348
Get alerted when CVE-2018-18386 or the next vulnerability affects your stack