What’s Vulnerable › Vulnerabilities
CVE-2018-18389
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-10-16 · updated 2026-06-17
- Weakness: CWE-287
Description
Due to incorrect access control in Neo4j Enterprise Database Server 3.4.x before 3.4.9, the setting of LDAP for authentication with STARTTLS, and System Account for authorization, allows an attacker to log into the server by sending any valid username with an arbitrary password.
Affected products
- Neo4j: from 3.4.0 before 3.4.9 — fixed in 3.4.9
How to fix
Upgrade to a fixed version: Neo4j 3.4.9. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2018-18389 or the next vulnerability affects your stack