What’s Vulnerable › Vulnerabilities
CVE-2018-18439
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-11-20 · updated 2026-06-17
- Weakness: CWE-119
Description
DENX U-Boot through 2018.09-rc1 has a remotely exploitable buffer overflow via a malicious TFTP server because TFTP traffic is mishandled. Also, local exploitation can occur via a crafted kernel image.
Affected products
- u-boot: before 2018.09; 2018.09-rc1 — fixed in 2018.09
How to fix
Upgrade to a fixed version: u-boot 2018.09. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2018/11/02/2
- http://www.openwall.com/lists/oss-security/2018/11/02/2
Get alerted when CVE-2018-18439 or the next vulnerability affects your stack