What’s Vulnerable › Vulnerabilities
CVE-2018-18445
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-10-17 · updated 2026-06-17
- Weakness: CWE-125
Description
In the Linux kernel 4.14.x, 4.15.x, 4.16.x, 4.17.x, and 4.18.x before 4.18.13, faulty computation of numeric bounds in the BPF verifier permits out-of-bounds memory accesses because adjust_scalar_min_max_vals in kernel/bpf/verifier.c mishandles 32-bit right shifts.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04, 18.10
- Linux kernel: from 4.14.9 before 4.14.75; from 4.15 before 4.18.13 — fixed in 4.14.75, 4.18.13
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Server: 7.0, 7.6
- RedHat Enterprise Linux Server Aus: 7.6
- RedHat Enterprise Linux Server Eus: 7.6
- RedHat Enterprise Linux Server Tus: 7.6
- RedHat Enterprise Linux Workstation: 7.0
How to fix
Upgrade to a fixed version: Linux kernel 4.14.75, 4.18.13. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=b799207e1e1816b09e7a5920fbb2d5fcf6edd681
- https://access.redhat.com/errata/RHSA-2019:0512
- https://access.redhat.com/errata/RHSA-2019:0514
- https://bugs.chromium.org/p/project-zero/issues/detail?id=1686
- https://cdn.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.14.75
- https://cdn.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.18.13
- https://github.com/torvalds/linux/commit/b799207e1e1816b09e7a5920fbb2d5fcf6edd681
- https://support.f5.com/csp/article/K38456756
- https://usn.ubuntu.com/3832-1/
- https://usn.ubuntu.com/3835-1/
- https://usn.ubuntu.com/3847-1/
- https://usn.ubuntu.com/3847-2/
Get alerted when CVE-2018-18445 or the next vulnerability affects your stack