What’s Vulnerable › Vulnerabilities
CVE-2018-18495
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-02-28 · updated 2026-06-17
- Weakness: CWE-732
Description
WebExtension content scripts can be loaded into about: pages in some circumstances, in violation of the permissions granted to extensions. This could allow an extension to interfere with the loading and usage of these pages and use capabilities that were intended to be restricted from extensions. This vulnerability affects Firefox < 64.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04, 18.10
- Mozilla Firefox: before 64.0 — fixed in 64.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 64.0. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/106167
- https://bugzilla.mozilla.org/show_bug.cgi?id=1427585
- https://usn.ubuntu.com/3844-1/
- https://www.mozilla.org/security/advisories/mfsa2018-29/
- http://www.securityfocus.com/bid/106167
- https://bugzilla.mozilla.org/show_bug.cgi?id=1427585
- https://usn.ubuntu.com/3844-1/
- https://www.mozilla.org/security/advisories/mfsa2018-29/
Get alerted when CVE-2018-18495 or the next vulnerability affects your stack