What’s Vulnerable › Vulnerabilities
CVE-2018-18501
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-02-05 · updated 2026-06-17
- Weakness: CWE-119
Description
Mozilla developers and community members reported memory safety bugs present in Firefox 64 and Firefox ESR 60.4. Some of these bugs showed evidence of memory corruption and we presume that with enough effort that some of these could be exploited to run arbitrary code. This vulnerability affects Thunderbird < 60.5, Firefox ESR < 60.5, and Firefox < 65.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04, 18.10
- Debian Linux: 8.0, 9.0
- Mozilla Firefox: before 65.0 — fixed in 65.0
- Mozilla Firefox ESR: before 60.5 — fixed in 60.5
- Mozilla Thunderbird: before 60.5 — fixed in 60.5
- RedHat Enterprise Linux Desktop: 6.0, 7.0
- RedHat Enterprise Linux Server: 6.0, 7.0
- RedHat Enterprise Linux Server Aus: 7.6
- RedHat Enterprise Linux Server Eus: 7.6
- RedHat Enterprise Linux Workstation: 6.0, 7.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 65.0; Mozilla Firefox ESR 60.5; Mozilla Thunderbird 60.5. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00021.html
- http://www.securityfocus.com/bid/106781
- https://access.redhat.com/errata/RHSA-2019:0218
- https://access.redhat.com/errata/RHSA-2019:0219
- https://access.redhat.com/errata/RHSA-2019:0269
- https://access.redhat.com/errata/RHSA-2019:0270
- https://lists.debian.org/debian-lts-announce/2019/01/msg00025.html
- https://lists.debian.org/debian-lts-announce/2019/02/msg00024.html
- https://security.gentoo.org/glsa/201903-04
- https://security.gentoo.org/glsa/201904-07
- https://usn.ubuntu.com/3874-1/
- https://usn.ubuntu.com/3897-1/
Get alerted when CVE-2018-18501 or the next vulnerability affects your stack