What’s Vulnerable › Vulnerabilities
CVE-2018-18506
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-02-05 · updated 2026-06-17
Description
When proxy auto-detection is enabled, if a web server serves a Proxy Auto-Configuration (PAC) file or if a PAC file is loaded locally, this PAC file can specify that requests to the localhost are to be sent through the proxy to another server. This behavior is disallowed by default when a proxy is manually configured, but when enabled could allow for attacks on services and tools that bind to the localhost for networked behavior if they are accessed through browsing. This vulnerability affects Firefox < 65.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04, 18.10
- Debian Linux: 8.0, 9.0
- Mozilla Firefox: before 65.0 — fixed in 65.0
- openSUSE Leap: 15.0, 42.3
- Red Hat Enterprise Linux: 8.0
- RedHat Enterprise Linux Desktop: 6.0, 7.0
- RedHat Enterprise Linux Eus: 8.1, 8.2, 8.4, 8.6
- RedHat Enterprise Linux Server: 6.0, 7.0
- RedHat Enterprise Linux Server Aus: 7.6, 8.2, 8.4, 8.6
- RedHat Enterprise Linux Server Eus: 7.6
- RedHat Enterprise Linux Server Tus: 7.6, 8.2, 8.4, 8.6
- RedHat Enterprise Linux Workstation: 6.0, 7.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 65.0. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-03/msg00035.html
- http://lists.opensuse.org/opensuse-security-announce/2019-03/msg00043.html
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00023.html
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00043.html
- http://www.securityfocus.com/bid/106773
- https://access.redhat.com/errata/RHSA-2019:0622
- https://access.redhat.com/errata/RHSA-2019:0623
- https://access.redhat.com/errata/RHSA-2019:0680
- https://access.redhat.com/errata/RHSA-2019:0681
- https://access.redhat.com/errata/RHSA-2019:0966
- https://access.redhat.com/errata/RHSA-2019:1144
- https://lists.debian.org/debian-lts-announce/2019/03/msg00024.html
Get alerted when CVE-2018-18506 or the next vulnerability affects your stack