What’s Vulnerable › Vulnerabilities
CVE-2018-1851
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-10-31 · updated 2026-06-17
- Weakness: CWE-502
Description
IBM WebSphere Application Server Liberty OpenID Connect could allow a remote attacker to execute arbitrary code on the system, caused by improper deserialization. By sending a specially-crafted request to the RP service, an attacker could exploit this vulnerability to execute arbitrary code. IBM X-Force ID: 150999.
Affected products
- IBM WebSphere Application Server: before 18.0.0.3 — fixed in 18.0.0.3
How to fix
Upgrade to a fixed version: IBM WebSphere Application Server 18.0.0.3. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/105839
- https://exchange.xforce.ibmcloud.com/vulnerabilities/150999
- https://www.ibm.com/support/docview.wss?uid=ibm10735105
- http://www.securityfocus.com/bid/105839
- https://exchange.xforce.ibmcloud.com/vulnerabilities/150999
- https://www.ibm.com/support/docview.wss?uid=ibm10735105
Get alerted when CVE-2018-1851 or the next vulnerability affects your stack