What’s Vulnerable › Vulnerabilities
CVE-2018-18517
- Severity: medium (CVSS 4.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-10-24 · updated 2026-06-17
- Weakness: CWE-79
Description
Citrix NetScaler Gateway 10.5.x before 10.5.69.003, 11.1.x before 11.1.59.004, 12.0.x before 12.0.58.7, and 12.1.x before 12.1.49.1 has XSS.
Affected products
- Citrix Netscaler Gateway Firmware: from 10.5.0 before 10.5.69.003; from 11.1.0 before 11.1.59.004; from 12.0.0 before 12.0.58.7; from 12.1.0 before 12.1.49.1 — fixed in 10.5.69.003, 11.1.59.004, 12.0.58.7, 12.1.49.1
How to fix
Upgrade to a fixed version: Citrix Netscaler Gateway Firmware 10.5.69.003, 11.1.59.004, 12.0.58.7, 12.1.49.1. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/105725
- http://www.securitytracker.com/id/1042023
- https://support.citrix.com/article/CTX239002
- http://www.securityfocus.com/bid/105725
- http://www.securitytracker.com/id/1042023
- https://support.citrix.com/article/CTX239002
Get alerted when CVE-2018-18517 or the next vulnerability affects your stack