What’s Vulnerable › Vulnerabilities
CVE-2018-18541
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-10-20 · updated 2026-06-17
- Weakness: CWE-20
Description
In Teeworlds before 0.6.5, connection packets could be forged. There was no challenge-response involved in the connection build up. A remote attacker could send connection packets from a spoofed IP address and occupy all server slots, or even use them for a reflection attack using map download packets.
Affected products
- Debian Linux: 9.0
- Teeworlds: before 0.6.5 — fixed in 0.6.5
How to fix
Upgrade to a fixed version: Teeworlds 0.6.5. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00046.html
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00077.html
- https://bugs.debian.org/911487
- https://github.com/teeworlds/teeworlds/issues/1536
- https://teeworlds.com/?page=news&id=12544
- https://www.debian.org/security/2018/dsa-4329
- http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00046.html
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00077.html
- https://bugs.debian.org/911487
- https://github.com/teeworlds/teeworlds/issues/1536
- https://teeworlds.com/?page=news&id=12544
- https://www.debian.org/security/2018/dsa-4329
Get alerted when CVE-2018-18541 or the next vulnerability affects your stack