What’s Vulnerable › Vulnerabilities
CVE-2018-18558
- Severity: medium (CVSS 6.4 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-05-13 · updated 2026-06-17
- Weakness: CWE-20
Description
An issue was discovered in Espressif ESP-IDF 2.x and 3.x before 3.0.6 and 3.1.x before 3.1.1. Insufficient validation of input data in the 2nd stage bootloader allows a physically proximate attacker to bypass secure boot checks and execute arbitrary code, by crafting an application binary that overwrites a bootloader code segment in process_segment in components/bootloader_support/src/esp_image_format.c. The attack is effective when the flash encryption feature is not enabled, or if the attacker finds a different vulnerability that allows them to write this binary to flash memory.
Affected products
- espressif esp-idf: from 2.0 before 3.0.6; from 3.1 through 3.1.1 — fixed in 3.0.6
How to fix
Upgrade to a fixed version: espressif esp-idf 3.0.6. Check the vendor advisory for mitigations.
References
- https://github.com/espressif/esp-idf/releases
- https://www.espressif.com/en/news/Espressif_Product_Security_Advisory_Concerning_Secure_Boot_%28CVE-2018-18558%29
- https://github.com/espressif/esp-idf/releases
- https://www.espressif.com/en/news/Espressif_Product_Security_Advisory_Concerning_Secure_Boot_%28CVE-2018-18558%29
Get alerted when CVE-2018-18558 or the next vulnerability affects your stack