What’s Vulnerable › Vulnerabilities
CVE-2018-18584
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-10-23 · updated 2026-06-17
- Weakness: CWE-787
Description
In mspack/cab.h in libmspack before 0.8alpha and cabextract before 1.8, the CAB block input buffer is one byte too small for the maximal Quantum block, leading to an out-of-bounds write.
Affected products
- Cabextract Project Cabextract: before 1.8 — fixed in 1.8
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04, 18.04, 18.10
- Debian Linux: 8.0
- Libmspack Project Libmspack: 0.3-alpha, 0.4-alpha, 0.5-alpha, 0.6-alpha, 0.7-alpha, 0.7.1-alpha
- Red Hat Enterprise Linux: 7.0
- Starwindsoftware Starwind Virtual San: all versions
- SUSE Linux Enterprise Server: 11-sp3, 12-ga, 12-sp1, 12-sp2
How to fix
Upgrade to a fixed version: Cabextract Project Cabextract 1.8. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2019:2049
- https://bugs.debian.org/911640
- https://github.com/kyz/libmspack/commit/40ef1b4093d77ad3a5cfcee1f5cb6108b3a3bcc2
- https://lists.debian.org/debian-lts-announce/2018/10/msg00017.html
- https://security.gentoo.org/glsa/201903-20
- https://usn.ubuntu.com/3814-1/
- https://usn.ubuntu.com/3814-2/
- https://usn.ubuntu.com/3814-3/
- https://www.cabextract.org.uk/#changes
- https://www.openwall.com/lists/oss-security/2018/10/22/1
- https://www.starwindsoftware.com/security/sw-20181213-0001/
- https://access.redhat.com/errata/RHSA-2019:2049
Get alerted when CVE-2018-18584 or the next vulnerability affects your stack