What’s Vulnerable › Vulnerabilities
CVE-2018-18648
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-12-04 · updated 2026-06-17
- Weakness: CWE-200
Description
An issue was discovered in GitLab Community and Enterprise Edition before 11.2.7, 11.3.x before 11.3.8, and 11.4.x before 11.4.3. It has Information Exposure Through an Error Message.
Affected products
- GitLab: from 11.2.0 before 11.2.7; from 11.3.0 before 11.3.8; from 11.4.0 before 11.4.3 — fixed in 11.2.7, 11.3.8, 11.4.3
How to fix
Upgrade to a fixed version: GitLab 11.2.7, 11.3.8, 11.4.3. Check the vendor advisory for mitigations.
References
- https://about.gitlab.com/2018/10/29/security-release-gitlab-11-dot-4-dot-3-released/
- https://gitlab.com/gitlab-org/gitlab-ce/issues/50975
- https://about.gitlab.com/2018/10/29/security-release-gitlab-11-dot-4-dot-3-released/
- https://gitlab.com/gitlab-org/gitlab-ce/issues/50975
Get alerted when CVE-2018-18648 or the next vulnerability affects your stack