What’s Vulnerable › Vulnerabilities
CVE-2018-18668
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-26 · updated 2026-06-17
- Weakness: CWE-79
Description
GNUBOARD5 before 5.3.2.0 has XSS that allows remote attackers to inject arbitrary web script or HTML via the "homepage title" parameter, aka the adm/config_form_update.php cf_title parameter.
Affected products
- gnuboard5: before 5.3.2.0 — fixed in 5.3.2.0
How to fix
Upgrade to a fixed version: gnuboard5 5.3.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/gnuboard/gnuboard5/commit/a45241f4bc46aee1ab2cc0749f6444b043681edf#diff-53f7f220c2d2861a98444adf09471496
- https://github.com/gnuboard/gnuboard5/compare/15b2e73...2549172
- https://github.com/gnuboard/gnuboard5/releases/tag/5.3.2.0
- https://github.com/gnuboard/gnuboard5/commit/a45241f4bc46aee1ab2cc0749f6444b043681edf#diff-53f7f220c2d2861a98444adf09471496
- https://github.com/gnuboard/gnuboard5/compare/15b2e73...2549172
- https://github.com/gnuboard/gnuboard5/releases/tag/5.3.2.0
Get alerted when CVE-2018-18668 or the next vulnerability affects your stack