What’s Vulnerable › Vulnerabilities
CVE-2018-18820
- Severity: high (CVSS 8.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 48.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-11-05 · updated 2026-06-17
- Weakness: CWE-119
Description
A buffer overflow was discovered in the URL-authentication backend of the Icecast before 2.4.4. If the backend is enabled, then any malicious HTTP client can send a request for that specific resource including a crafted header, leading to denial of service and potentially remote code execution.
Affected products
- Debian Linux: 8.0, 9.0
- Xiph Icecast: before 2.4.4 — fixed in 2.4.4
How to fix
Upgrade to a fixed version: Xiph Icecast 2.4.4. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2018/11/01/3
- http://www.securitytracker.com/id/1042019
- https://lists.debian.org/debian-lts-announce/2018/11/msg00033.html
- https://security.gentoo.org/glsa/201811-09
- https://www.debian.org/security/2018/dsa-4333
- http://www.openwall.com/lists/oss-security/2018/11/01/3
- http://www.securitytracker.com/id/1042019
- https://lists.debian.org/debian-lts-announce/2018/11/msg00033.html
- https://security.gentoo.org/glsa/201811-09
- https://www.debian.org/security/2018/dsa-4333
Get alerted when CVE-2018-18820 or the next vulnerability affects your stack