What’s Vulnerable › Vulnerabilities
CVE-2018-18843
- Severity: critical (CVSS 10.0 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-12-04 · updated 2026-06-17
- Weakness: CWE-918
Description
The Kubernetes integration in GitLab Enterprise Edition 11.x before 11.2.8, 11.3.x before 11.3.9, and 11.4.x before 11.4.4 has SSRF.
Affected products
- GitLab: from 11.0.0 before 11.2.8; from 11.3.0 before 11.3.9; from 11.4.0 before 11.4.4 — fixed in 11.2.8, 11.3.9, 11.4.4
How to fix
Upgrade to a fixed version: GitLab 11.2.8, 11.3.9, 11.4.4. Check the vendor advisory for mitigations.
References
- https://about.gitlab.com/2018/11/01/critical-security-release-gitlab-11-dot-4-dot-4-released/
- https://gitlab.com/gitlab-org/gitlab-ce/issues/53158
- https://about.gitlab.com/2018/11/01/critical-security-release-gitlab-11-dot-4-dot-4-released/
- https://gitlab.com/gitlab-org/gitlab-ce/issues/53158
Get alerted when CVE-2018-18843 or the next vulnerability affects your stack