What’s Vulnerable › Vulnerabilities
CVE-2018-18850
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 12.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-10-31 · updated 2026-06-17
Description
In Octopus Deploy 2018.8.0 through 2018.9.x before 2018.9.1, an authenticated user with permission to modify deployment processes could upload a maliciously crafted YAML configuration, potentially allowing for remote execution of arbitrary code, running in the same context as the Octopus Server (for self-hosted installations by default, SYSTEM).
Affected products
- Octopus Deploy Octopus Server: from 2018.8.0 through 2018.8.12; from 2018.9.0 before 2018.9.1 — fixed in 2018.9.1
How to fix
Upgrade to a fixed version: Octopus Deploy Octopus Server 2018.9.1. Check the vendor advisory for mitigations.
References
- https://github.com/OctopusDeploy/Issues/issues/5042
- https://github.com/OctopusDeploy/Issues/issues/5042
Get alerted when CVE-2018-18850 or the next vulnerability affects your stack