What’s Vulnerable › Vulnerabilities
CVE-2018-18903
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-11-03 · updated 2026-06-17
- Weakness: CWE-94
Description
Vanilla 2.6.x before 2.6.4 allows remote code execution.
Affected products
- Vanilla Forums: from 2.6.0 before 2.6.4 — fixed in 2.6.4
How to fix
Upgrade to a fixed version: Vanilla Forums 2.6.4. Check the vendor advisory for mitigations.
References
- https://github.com/vanilla/vanilla/releases/tag/Vanilla_2.6.4
- https://open.vanillaforums.com/discussion/36771/security-update-vanilla-2-6-4
- https://srcincite.io/blog/2018/10/02/old-school-pwning-with-new-school-tricks-vanilla-forums-remote-code-execution.html
- https://github.com/vanilla/vanilla/releases/tag/Vanilla_2.6.4
- https://open.vanillaforums.com/discussion/36771/security-update-vanilla-2-6-4
- https://srcincite.io/blog/2018/10/02/old-school-pwning-with-new-school-tricks-vanilla-forums-remote-code-execution.html
Get alerted when CVE-2018-18903 or the next vulnerability affects your stack