What’s Vulnerable › Vulnerabilities
CVE-2018-18921
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-12-18 · updated 2026-06-17
- Weakness: CWE-352
Description
PHP Server Monitor before 3.3.2 has CSRF, as demonstrated by a Delete action.
Affected products
- phpservermon: before 3.3.2 — fixed in 3.3.2
How to fix
Upgrade to a fixed version: phpservermon 3.3.2. Check the vendor advisory for mitigations.
References
- https://github.com/phpservermon/phpservermon/issues/670
- https://medium.com/bugbountywriteup/cve-2018-18921-php-server-monitor-3-3-1-cross-site-request-forgery-a73e8dae563
- https://github.com/phpservermon/phpservermon/issues/670
- https://medium.com/bugbountywriteup/cve-2018-18921-php-server-monitor-3-3-1-cross-site-request-forgery-a73e8dae563
Get alerted when CVE-2018-18921 or the next vulnerability affects your stack