What’s Vulnerable › Vulnerabilities
CVE-2018-18926
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-11-04 · updated 2026-06-17
- Weakness: CWE-384
Description
Gitea before 1.5.4 allows remote code execution because it does not properly validate session IDs. This is related to session ID handling in the go-macaron/session code for Macaron.
Affected products
- Gitea Open Source Git Server: before 1.5.4 — fixed in 1.5.4
How to fix
Upgrade to a fixed version: Gitea Open Source Git Server 1.5.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2018-18926 or the next vulnerability affects your stack