What’s Vulnerable › Vulnerabilities
CVE-2018-18942
- Severity: high (CVSS 7.2 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-11-05 · updated 2026-06-17
- Weakness: CWE-434
Description
In baserCMS before 4.1.4, lib\Baser\Model\ThemeConfig.php allows remote attackers to execute arbitrary PHP code via the admin/theme_configs/form data[ThemeConfig][logo] parameter.
Affected products
- baserproject basercms: before 4.1.4 — fixed in 4.1.4
How to fix
Upgrade to a fixed version: baserproject basercms 4.1.4. Check the vendor advisory for mitigations.
References
- http://sunu11.com/2018/10/31/baserCMS/
- https://basercms.net/release/4_1_4
- https://github.com/baserproject/basercms/issues/959
- http://sunu11.com/2018/10/31/baserCMS/
- https://basercms.net/release/4_1_4
- https://github.com/baserproject/basercms/issues/959
Get alerted when CVE-2018-18942 or the next vulnerability affects your stack