What’s Vulnerable › Vulnerabilities
CVE-2018-18954
- Severity: medium (CVSS 5.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-11-15 · updated 2026-06-17
- Weakness: CWE-125
Description
The pnv_lpc_do_eccb function in hw/ppc/pnv_lpc.c in Qemu before 3.1 allows out-of-bounds write or read access to PowerNV memory.
Affected products
- Canonical Ubuntu Linux: 18.04, 18.10
- openSUSE Leap: 42.3
- QEMU: before 3.1 — fixed in 3.1
How to fix
Upgrade to a fixed version: QEMU 3.1. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-03/msg00042.html
- http://www.openwall.com/lists/oss-security/2018/11/06/6
- http://www.securityfocus.com/bid/105920
- https://lists.gnu.org/archive/html/qemu-devel/2018-11/msg00446.html
- https://seclists.org/bugtraq/2019/May/76
- https://usn.ubuntu.com/3826-1/
- https://www.debian.org/security/2019/dsa-4454
- http://lists.opensuse.org/opensuse-security-announce/2019-03/msg00042.html
- http://www.openwall.com/lists/oss-security/2018/11/06/6
- http://www.securityfocus.com/bid/105920
- https://lists.gnu.org/archive/html/qemu-devel/2018-11/msg00446.html
- https://seclists.org/bugtraq/2019/May/76
Get alerted when CVE-2018-18954 or the next vulnerability affects your stack