What’s Vulnerable › Vulnerabilities
CVE-2018-19005
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-12-20 · updated 2026-06-17
- Weakness: CWE-20
Description
Cscape, Version 9.80.75.3 SP3 and prior. An improper input validation vulnerability has been identified that may be exploited by processing specially crafted POC files lacking user input validation. This may allow an attacker to read confidential information and remotely execute arbitrary code.
Affected products
- Horner Automation Cscape: before 9.80.75.3; 9.80.75.3, 9.80.75.3-sp1, 9.80.75.3-sp2, 9.80.75.3-sp3 — fixed in 9.80.75.3
How to fix
Upgrade to a fixed version: Horner Automation Cscape 9.80.75.3. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/106275
- https://ics-cert.us-cert.gov/advisories/ICSA-18-354-01
- http://www.securityfocus.com/bid/106275
- https://ics-cert.us-cert.gov/advisories/ICSA-18-354-01
Get alerted when CVE-2018-19005 or the next vulnerability affects your stack