What’s Vulnerable › Vulnerabilities
CVE-2018-19009
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-01-25 · updated 2026-06-17
- Weakness: CWE-312
Description
Pilz PNOZmulti Configurator prior to version 10.9 allows an authenticated attacker with local access to the system containing the PNOZmulti Configurator software to view sensitive credential data in clear-text. This sensitive data is applicable to only the PMI m107 diag HMI device. An attacker with access to this sensitive data and physical access to the PMI m107 diag can modify data on the HMI device.
Affected products
- PILZ PNOZmulti Configurator: before 10.9.0 — fixed in 10.9.0
How to fix
Upgrade to a fixed version: PILZ PNOZmulti Configurator 10.9.0. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/106529
- https://ics-cert.us-cert.gov/advisories/ICSA-19-010-03
- http://www.securityfocus.com/bid/106529
- https://ics-cert.us-cert.gov/advisories/ICSA-19-010-03
Get alerted when CVE-2018-19009 or the next vulnerability affects your stack