What’s Vulnerable › Vulnerabilities
CVE-2018-19029
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-02-05 · updated 2026-06-17
- Weakness: CWE-822
Description
LCDS Laquis SCADA prior to version 4.1.0.4150 allows an attacker using a specially crafted project file to supply a pointer for a controlled memory address, which may allow remote code execution, data exfiltration, or cause a system crash.
Affected products
- ICS-CERT LCDS Laquis SCADA: before 4.1.0.4150 — fixed in 4.1.0.4150
How to fix
Upgrade to a fixed version: ICS-CERT LCDS Laquis SCADA 4.1.0.4150. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/106634
- https://ics-cert.us-cert.gov/advisories/ICSA-19-015-01
- http://www.securityfocus.com/bid/106634
- https://ics-cert.us-cert.gov/advisories/ICSA-19-015-01
Get alerted when CVE-2018-19029 or the next vulnerability affects your stack