What’s Vulnerable › Vulnerabilities
CVE-2018-19115
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-11-08 · updated 2026-06-17
- Weakness: CWE-787
Description
keepalived before 2.0.7 has a heap-based buffer overflow when parsing HTTP status codes resulting in DoS or possibly unspecified other impact, because extract_status_code in lib/html.c has no validation of the status code and instead writes an unlimited amount of data to the heap.
Affected products
- Debian Linux: 8.0
- Keepalived: before 2.0.7 — fixed in 2.0.7
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Server Aus: 7.6
- RedHat Enterprise Linux Server Eus: 7.6
- RedHat Enterprise Linux Server Tus: 7.6
- RedHat Enterprise Linux Workstation: 7.0
How to fix
Upgrade to a fixed version: Keepalived 2.0.7. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2019:0022
- https://access.redhat.com/errata/RHSA-2019:1792
- https://access.redhat.com/errata/RHSA-2019:1945
- https://bugzilla.suse.com/show_bug.cgi?id=1015141
- https://github.com/acassen/keepalived/pull/961
- https://github.com/acassen/keepalived/pull/961/commits/f28015671a4b04785859d1b4b1327b367b6a10e9
- https://lists.debian.org/debian-lts-announce/2018/11/msg00034.html
- https://security.gentoo.org/glsa/201903-01
- https://usn.ubuntu.com/3995-1/
- https://usn.ubuntu.com/3995-2/
- https://access.redhat.com/errata/RHSA-2019:0022
- https://access.redhat.com/errata/RHSA-2019:1792
Get alerted when CVE-2018-19115 or the next vulnerability affects your stack