What’s Vulnerable › Vulnerabilities
CVE-2018-19125
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 10.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-11-09 · updated 2026-06-17
Description
PrestaShop 1.6.x before 1.6.1.23 and 1.7.x before 1.7.4.4 allows remote attackers to delete an image directory.
Affected products
- PrestaShop: from 1.6.0.1 before 1.6.1.23; from 1.7.0.0 before 1.7.4.4 — fixed in 1.6.1.23, 1.7.4.4
How to fix
Upgrade to a fixed version: PrestaShop 1.6.1.23, 1.7.4.4. Check the vendor advisory for mitigations.
References
- http://build.prestashop.com/news/prestashop-1-7-4-4-1-6-1-23-maintenance-releases/
- https://github.com/PrestaShop/PrestaShop/pull/11285
- https://github.com/PrestaShop/PrestaShop/pull/11286
- https://www.exploit-db.com/exploits/45964/
- http://build.prestashop.com/news/prestashop-1-7-4-4-1-6-1-23-maintenance-releases/
- https://github.com/PrestaShop/PrestaShop/pull/11285
- https://github.com/PrestaShop/PrestaShop/pull/11286
- https://www.exploit-db.com/exploits/45964/
Get alerted when CVE-2018-19125 or the next vulnerability affects your stack