What’s Vulnerable › Vulnerabilities
CVE-2018-19131
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-11-09 · updated 2026-06-17
- Weakness: CWE-79
Description
Squid before 4.4 has XSS via a crafted X.509 certificate during HTTP(S) error page generation for certificate errors.
Affected products
- Squid: before 4.4 — fixed in 4.4
How to fix
Upgrade to a fixed version: Squid 4.4. Check the vendor advisory for mitigations.
References
- http://www.squid-cache.org/Advisories/SQUID-2018_4.txt
- http://www.squid-cache.org/Versions/v5/changesets/squid-5-6feeb15ff312f3e145763adf8d234ed6a0b3f11d.patch
- https://github.com/squid-cache/squid/pull/306
- http://www.squid-cache.org/Advisories/SQUID-2018_4.txt
- http://www.squid-cache.org/Versions/v5/changesets/squid-5-6feeb15ff312f3e145763adf8d234ed6a0b3f11d.patch
- https://github.com/squid-cache/squid/pull/306
Get alerted when CVE-2018-19131 or the next vulnerability affects your stack