What’s Vulnerable › Vulnerabilities
CVE-2018-19132
- Severity: medium (CVSS 5.9 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-11-09 · updated 2026-06-17
- Weakness: CWE-772
Description
Squid before 4.4, when SNMP is enabled, allows a denial of service (Memory Leak) via an SNMP packet.
Affected products
- Debian Linux: 8.0
- Squid: before 4.4 — fixed in 4.4
How to fix
Upgrade to a fixed version: Squid 4.4. Check the vendor advisory for mitigations.
References
- http://www.squid-cache.org/Advisories/SQUID-2018_5.txt
- http://www.squid-cache.org/Versions/v5/changesets/squid-5-644131ff1e00c1895d77561f561d29c104ba6b11.patch
- https://github.com/squid-cache/squid/pull/313
- https://lists.debian.org/debian-lts-announce/2018/11/msg00032.html
- https://lists.debian.org/debian-lts-announce/2020/07/msg00009.html
- https://usn.ubuntu.com/4059-1/
- http://www.squid-cache.org/Advisories/SQUID-2018_5.txt
- http://www.squid-cache.org/Versions/v5/changesets/squid-5-644131ff1e00c1895d77561f561d29c104ba6b11.patch
- https://github.com/squid-cache/squid/pull/313
- https://lists.debian.org/debian-lts-announce/2018/11/msg00032.html
- https://lists.debian.org/debian-lts-announce/2020/07/msg00009.html
- https://usn.ubuntu.com/4059-1/
Get alerted when CVE-2018-19132 or the next vulnerability affects your stack