What’s Vulnerable › Vulnerabilities
CVE-2018-19149
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-11-10 · updated 2026-06-17
- Weakness: CWE-476
Description
Poppler before 0.70.0 has a NULL pointer dereference in _poppler_attachment_new when called from poppler_annot_file_attachment_get_attachment.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04, 18.10
- poppler: before 0.70.0 — fixed in 0.70.0
How to fix
Upgrade to a fixed version: poppler 0.70.0. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/106031
- https://access.redhat.com/errata/RHSA-2019:2022
- https://gitlab.freedesktop.org/poppler/poppler/issues/664
- https://security.gentoo.org/glsa/201904-04
- https://usn.ubuntu.com/3837-1/
- https://usn.ubuntu.com/3837-2/
- http://www.securityfocus.com/bid/106031
- https://access.redhat.com/errata/RHSA-2019:2022
- https://gitlab.freedesktop.org/poppler/poppler/issues/664
- https://security.gentoo.org/glsa/201904-04
- https://usn.ubuntu.com/3837-1/
- https://usn.ubuntu.com/3837-2/
Get alerted when CVE-2018-19149 or the next vulnerability affects your stack