What’s Vulnerable › Vulnerabilities
CVE-2018-19198
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-11-12 · updated 2026-06-17
- Weakness: CWE-787
Description
An issue was discovered in uriparser before 0.9.0. UriQuery.c allows an out-of-bounds write via a uriComposeQuery* or uriComposeQueryEx* function because the '&' character is mishandled in certain contexts.
Affected products
- Debian Linux: 8.0
- uriparser: before 0.9.0 — fixed in 0.9.0
How to fix
Upgrade to a fixed version: uriparser 0.9.0. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2019:2280
- https://github.com/uriparser/uriparser/blob/uriparser-0.9.0/ChangeLog
- https://github.com/uriparser/uriparser/commit/864f5d4c127def386dd5cc926ad96934b297f04e
- https://lists.debian.org/debian-lts-announce/2018/11/msg00019.html
- https://access.redhat.com/errata/RHSA-2019:2280
- https://github.com/uriparser/uriparser/blob/uriparser-0.9.0/ChangeLog
- https://github.com/uriparser/uriparser/commit/864f5d4c127def386dd5cc926ad96934b297f04e
- https://lists.debian.org/debian-lts-announce/2018/11/msg00019.html
Get alerted when CVE-2018-19198 or the next vulnerability affects your stack