What’s Vulnerable › Vulnerabilities
CVE-2018-19199
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-11-12 · updated 2026-06-17
- Weakness: CWE-190
Description
An issue was discovered in uriparser before 0.9.0. UriQuery.c allows an integer overflow via a uriComposeQuery* or uriComposeQueryEx* function because of an unchecked multiplication.
Affected products
- Debian Linux: 8.0
- uriparser: before 0.9.0 — fixed in 0.9.0
How to fix
Upgrade to a fixed version: uriparser 0.9.0. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2019:2280
- https://github.com/uriparser/uriparser/blob/uriparser-0.9.0/ChangeLog
- https://github.com/uriparser/uriparser/commit/f76275d4a91b28d687250525d3a0c5509bbd666f
- https://lists.debian.org/debian-lts-announce/2018/11/msg00019.html
- https://access.redhat.com/errata/RHSA-2019:2280
- https://github.com/uriparser/uriparser/blob/uriparser-0.9.0/ChangeLog
- https://github.com/uriparser/uriparser/commit/f76275d4a91b28d687250525d3a0c5509bbd666f
- https://lists.debian.org/debian-lts-announce/2018/11/msg00019.html
Get alerted when CVE-2018-19199 or the next vulnerability affects your stack