What’s Vulnerable › Vulnerabilities
CVE-2018-19200
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-11-12 · updated 2026-06-17
- Weakness: CWE-476
Description
An issue was discovered in uriparser before 0.9.0. UriCommon.c allows attempted operations on NULL input via a uriResetUri* function.
Affected products
- Debian Linux: before 8.0 — fixed in 8.0
- uriparser: before 0.9.0 — fixed in 0.9.0
How to fix
Upgrade to a fixed version: Debian Linux 8.0; uriparser 0.9.0. Check the vendor advisory for mitigations.
References
- https://github.com/uriparser/uriparser/blob/uriparser-0.9.0/ChangeLog
- https://github.com/uriparser/uriparser/commit/f58c25069cf4a986fe17a80c5b38687e31feb539
- https://lists.debian.org/debian-lts-announce/2018/11/msg00019.html
- https://github.com/uriparser/uriparser/blob/uriparser-0.9.0/ChangeLog
- https://github.com/uriparser/uriparser/commit/f58c25069cf4a986fe17a80c5b38687e31feb539
- https://lists.debian.org/debian-lts-announce/2018/11/msg00019.html
Get alerted when CVE-2018-19200 or the next vulnerability affects your stack