What’s Vulnerable › Vulnerabilities
CVE-2018-19207
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 88.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-11-12 · updated 2026-06-17
- Weakness: CWE-425
Description
The Van Ons WP GDPR Compliance (aka wp-gdpr-compliance) plugin before 1.4.3 for WordPress allows remote attackers to execute arbitrary code because $wpdb->prepare() input is mishandled, as exploited in the wild in November 2018.
Affected products
- Van-Ons Wp-Gdpr-Compliance: before 1.4.3 — fixed in 1.4.3
How to fix
Upgrade to a fixed version: Van-Ons Wp-Gdpr-Compliance 1.4.3. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/105921
- https://wordpress.org/plugins/wp-gdpr-compliance/#developers
- https://wpvulndb.com/vulnerabilities/9144
- https://www.wordfence.com/blog/2018/11/trends-following-vulnerability-in-wp-gdpr-compliance-plugin/
- http://www.securityfocus.com/bid/105921
- https://wordpress.org/plugins/wp-gdpr-compliance/#developers
- https://wpvulndb.com/vulnerabilities/9144
- https://www.wordfence.com/blog/2018/11/trends-following-vulnerability-in-wp-gdpr-compliance-plugin/
Get alerted when CVE-2018-19207 or the next vulnerability affects your stack