What’s Vulnerable › Vulnerabilities
CVE-2018-19296
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-11-16 · updated 2026-06-17
- Weakness: CWE-502
Description
PHPMailer before 5.2.27 and 6.x before 6.0.6 is vulnerable to an object injection attack.
Affected products
- Debian Linux: 8.0, 9.0
- Fedoraproject Fedora: 33, 34
- Phpmailer Project Phpmailer: before 5.2.27; from 6.0.0 before 6.0.6 — fixed in 5.2.27, 6.0.6
- WordPress: from 3.7 through 5.7
How to fix
Upgrade to a fixed version: Phpmailer Project Phpmailer 5.2.27, 6.0.6. Check the vendor advisory for mitigations.
References
- https://github.com/PHPMailer/PHPMailer/releases/tag/v5.2.27
- https://github.com/PHPMailer/PHPMailer/releases/tag/v6.0.6
- https://lists.debian.org/debian-lts-announce/2018/12/msg00020.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/3B5WDPGUFNPG4NAZ6G4BZX43BKLAVA5B/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/KPU66INRFY5BQ3ESVPRUXJR4DXQAFJVT/
- https://www.debian.org/security/2018/dsa-4351
- https://github.com/PHPMailer/PHPMailer/releases/tag/v5.2.27
- https://github.com/PHPMailer/PHPMailer/releases/tag/v6.0.6
- https://lists.debian.org/debian-lts-announce/2018/12/msg00020.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/3B5WDPGUFNPG4NAZ6G4BZX43BKLAVA5B/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/KPU66INRFY5BQ3ESVPRUXJR4DXQAFJVT/
- https://www.debian.org/security/2018/dsa-4351
Get alerted when CVE-2018-19296 or the next vulnerability affects your stack