What’s Vulnerable › Vulnerabilities
CVE-2018-19322: GIGABYTE Multiple Products Code Execution Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2022-10-24
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-12-21 · updated 2026-08-13
- Weakness: CWE-749
Description
The GPCIDrv and GDrv low-level drivers in GIGABYTE APP Center v1.05.21 and earlier, AORUS GRAPHICS ENGINE before 1.57, XTREME GAMING ENGINE before 1.26, and OC GURU II v2.08 expose functionality to read/write data from/to IO ports. This could be leveraged in a number of ways to ultimately run code with elevated privileges.
Affected products
- Gigabyte Aorus Graphics Engine: before 1.57 — fixed in 1.57
- Gigabyte App Center: through 1.05.21
- Gigabyte Oc Guru Ii: 2.08
- Gigabyte Xtreme Gaming Engine: before 1.26 — fixed in 1.26
How to fix
Upgrade to a fixed version: Gigabyte Aorus Graphics Engine 1.57; Gigabyte Xtreme Gaming Engine 1.26. Check the vendor advisory for mitigations.
References
- http://seclists.org/fulldisclosure/2018/Dec/39
- http://www.securityfocus.com/bid/106252
- https://www.gigabyte.com/Support/Security/1801
- https://www.gigabyte.com/tw/Support/Utility/Graphics-Card
- https://www.secureauth.com/labs/advisories/gigabyte-drivers-elevation-privilege-vulnerabilities
- http://seclists.org/fulldisclosure/2018/Dec/39
- http://www.securityfocus.com/bid/106252
- https://www.gigabyte.com/Support/Security/1801
- https://www.gigabyte.com/tw/Support/Utility/Graphics-Card
- https://www.secureauth.com/labs/advisories/gigabyte-drivers-elevation-privilege-vulnerabilities
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2018-19322
Get alerted when CVE-2018-19322 or the next vulnerability affects your stack