What’s Vulnerable › Vulnerabilities
CVE-2018-19359
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-04-25 · updated 2026-06-17
Description
GitLab Community and Enterprise Edition 8.9 and later and before 11.5.0-rc12, 11.4.6, and 11.3.10 has Incorrect Access Control.
Affected products
- GitLab: from 11.3.0 before 11.3.10; from 11.4.0 before 11.4.6; from 11.4.7 through 11.4.9; 11.5.0, 11.5.0-rc1, 11.5.0-rc10, 11.5.0-rc11, 11.5.0-rc2, 11.5.0-rc3 (+6) — fixed in 11.3.10, 11.4.6
How to fix
Upgrade to a fixed version: GitLab 11.3.10, 11.4.6. Check the vendor advisory for mitigations.
References
- https://about.gitlab.com/2018/11/19/critical-security-release-gitlab-11-dot-4-dot-6-released/
- https://about.gitlab.com/blog/categories/releases/
- https://gitlab.com/gitlab-org/gitlab-ce/issues/54189
- https://about.gitlab.com/2018/11/19/critical-security-release-gitlab-11-dot-4-dot-6-released/
- https://about.gitlab.com/blog/categories/releases/
- https://gitlab.com/gitlab-org/gitlab-ce/issues/54189
Get alerted when CVE-2018-19359 or the next vulnerability affects your stack