What’s Vulnerable › Vulnerabilities
CVE-2018-19409
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-11-21 · updated 2026-06-17
Description
An issue was discovered in Artifex Ghostscript before 9.26. LockSafetyParams is not checked correctly if another device is used.
Affected products
- Artifex Ghostscript: before 9.26 — fixed in 9.26
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04, 18.10
- Debian Linux: 8.0, 9.0
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Server Aus: 7.6
- RedHat Enterprise Linux Server Eus: 7.6
- RedHat Enterprise Linux Workstation: 7.0
How to fix
Upgrade to a fixed version: Artifex Ghostscript 9.26. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/105990
- https://access.redhat.com/errata/RHSA-2018:3834
- https://bugs.ghostscript.com/show_bug.cgi?id=700176
- https://git.ghostscript.com/?p=ghostpdl.git%3Ba=commit%3Bh=661e8d8fb8248c38d67958beda32f3a5876d0c3f
- https://lists.debian.org/debian-lts-announce/2018/11/msg00036.html
- https://security.gentoo.org/glsa/201811-12
- https://usn.ubuntu.com/3831-1/
- https://www.debian.org/security/2018/dsa-4346
- https://www.ghostscript.com/doc/9.26/History9.htm#Version9.26
- http://www.securityfocus.com/bid/105990
- https://access.redhat.com/errata/RHSA-2018:3834
- https://bugs.ghostscript.com/show_bug.cgi?id=700176
Get alerted when CVE-2018-19409 or the next vulnerability affects your stack