What’s Vulnerable › Vulnerabilities
CVE-2018-19417
- Severity: critical (CVSS 10.0 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-11-21 · updated 2026-06-17
- Weakness: CWE-119
Description
An issue was discovered in the MQTT server in Contiki-NG before 4.2. The function parse_publish_vhdr() that parses MQTT PUBLISH messages with a variable length header uses memcpy to input data into a fixed size buffer. The allocated buffer can fit only MQTT_MAX_TOPIC_LENGTH (default 64) bytes, and a length check is missing. This could lead to Remote Code Execution via a stack-smashing attack (overwriting the function return address). Contiki-NG does not separate the MQTT server from other servers and the OS modules, so access to all memory regions is possible.
Affected products
- contiki-ng: before 4.2 — fixed in 4.2
How to fix
Upgrade to a fixed version: contiki-ng 4.2. Check the vendor advisory for mitigations.
References
- https://github.com/contiki-ng/contiki-ng/issues/600
- https://github.com/contiki-ng/contiki-ng/issues/600
Get alerted when CVE-2018-19417 or the next vulnerability affects your stack