What’s Vulnerable › Vulnerabilities
CVE-2018-19466
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-03-27 · updated 2026-06-17
- Weakness: CWE-522
Description
A vulnerability was found in Portainer before 1.20.0. Portainer stores LDAP credentials, corresponding to a master password, in cleartext and allows their retrieval via API calls.
Affected products
- portainer: before 1.20.0 — fixed in 1.20.0
How to fix
Upgrade to a fixed version: portainer 1.20.0. Check the vendor advisory for mitigations.
References
- https://github.com/MauroEldritch/lempo
- https://github.com/portainer/portainer/pull/2488
- https://github.com/portainer/portainer/releases
- https://github.com/MauroEldritch/lempo
- https://github.com/portainer/portainer/pull/2488
- https://github.com/portainer/portainer/releases
Get alerted when CVE-2018-19466 or the next vulnerability affects your stack