What’s Vulnerable › Vulnerabilities
CVE-2018-19476
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-11-23 · updated 2026-06-17
- Weakness: CWE-704
Description
psi/zicc.c in Artifex Ghostscript before 9.26 allows remote attackers to bypass intended access restrictions because of a setcolorspace type confusion.
Affected products
- Artifex Ghostscript: before 9.26 — fixed in 9.26
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04, 18.10
- Debian Linux: 8.0, 9.0
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Server: 7.0, 7.6
- RedHat Enterprise Linux Server Aus: 7.6
- RedHat Enterprise Linux Server Eus: 7.6
- RedHat Enterprise Linux Server Tus: 7.6
- RedHat Enterprise Linux Workstation: 7.0
- Red Hat OpenShift Container Platform 4.18: 3.11
How to fix
Upgrade to a fixed version: Artifex Ghostscript 9.26. Check the vendor advisory for mitigations.
References
- http://git.ghostscript.com/?p=ghostpdl.git%3Ba=commit%3Bh=67d760ab775dae4efe803b5944b0439aa3c0b04a
- http://git.ghostscript.com/?p=ghostpdl.git%3Bh=434753adbe8be5534bfb9b7d91746023e8073d16
- http://www.securityfocus.com/bid/106154
- https://access.redhat.com/errata/RHBA-2019:0327
- https://access.redhat.com/errata/RHSA-2019:0229
- https://bugs.ghostscript.com/show_bug.cgi?id=700169
- https://lists.debian.org/debian-lts-announce/2018/11/msg00036.html
- https://semmle.com/news/semmle-discovers-severe-vulnerability-ghostscript-postscript-pdf
- https://usn.ubuntu.com/3831-1/
- https://www.debian.org/security/2018/dsa-4346
- https://www.ghostscript.com/doc/9.26/History9.htm#Version9.26
- http://git.ghostscript.com/?p=ghostpdl.git%3Ba=commit%3Bh=67d760ab775dae4efe803b5944b0439aa3c0b04a
Get alerted when CVE-2018-19476 or the next vulnerability affects your stack