What’s Vulnerable › Vulnerabilities
CVE-2018-19478
- Severity: medium (CVSS 5.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-01-02 · updated 2026-06-17
- Weakness: CWE-20
Description
In Artifex Ghostscript before 9.26, a carefully crafted PDF file can trigger an extremely long running computation when parsing the file.
Affected products
- Artifex Ghostscript: before 9.26 — fixed in 9.26
- Debian Linux: 8.0
How to fix
Upgrade to a fixed version: Artifex Ghostscript 9.26. Check the vendor advisory for mitigations.
References
- http://git.ghostscript.com/?p=ghostpdl.git%3Ba=commitdiff%3Bh=0a7e5a1c309fa0911b892fa40996a7d55d90bace
- http://www.securityfocus.com/bid/106445
- https://bugs.ghostscript.com/show_bug.cgi?id=699856
- https://bugzilla.redhat.com/show_bug.cgi?id=1655607
- https://lists.debian.org/debian-lts-announce/2018/12/msg00019.html
- https://www.ghostscript.com/doc/9.26/History9.htm
- http://git.ghostscript.com/?p=ghostpdl.git%3Ba=commitdiff%3Bh=0a7e5a1c309fa0911b892fa40996a7d55d90bace
- http://www.securityfocus.com/bid/106445
- https://bugs.ghostscript.com/show_bug.cgi?id=699856
- https://bugzilla.redhat.com/show_bug.cgi?id=1655607
- https://lists.debian.org/debian-lts-announce/2018/12/msg00019.html
- https://www.ghostscript.com/doc/9.26/History9.htm
Get alerted when CVE-2018-19478 or the next vulnerability affects your stack