What’s Vulnerable › Vulnerabilities
CVE-2018-19486
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-11-23 · updated 2026-06-17
- Weakness: CWE-426
Description
Git before 2.19.2 on Linux and UNIX executes commands from the current working directory (as if '.' were at the end of $PATH) in certain cases involving the run_command() API and run-command.c, because there was a dangerous change from execvp to execv during 2017.
Affected products
- Canonical Ubuntu Linux: 18.04, 18.10
- git: before 2.19.2 — fixed in 2.19.2
How to fix
Upgrade to a fixed version: git 2.19.2. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/106020
- http://www.securitytracker.com/id/1042166
- https://access.redhat.com/errata/RHSA-2018:3800
- https://git.kernel.org/pub/scm/git/git.git/commit/?id=321fd82389742398d2924640ce3a61791fd27d60
- https://git.kernel.org/pub/scm/git/git.git/tree/Documentation/RelNotes/2.19.2.txt
- https://security.gentoo.org/glsa/201904-13
- https://usn.ubuntu.com/3829-1/
- http://www.securityfocus.com/bid/106020
- http://www.securitytracker.com/id/1042166
- https://access.redhat.com/errata/RHSA-2018:3800
- https://git.kernel.org/pub/scm/git/git.git/commit/?id=321fd82389742398d2924640ce3a61791fd27d60
- https://git.kernel.org/pub/scm/git/git.git/tree/Documentation/RelNotes/2.19.2.txt
Get alerted when CVE-2018-19486 or the next vulnerability affects your stack