What’s Vulnerable › Vulnerabilities
CVE-2018-19499
- Severity: high (CVSS 7.2 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-11-23 · updated 2026-06-17
- Weakness: CWE-502
Description
Vanilla before 2.5.5 and 2.6.x before 2.6.2 allows Remote Code Execution because authenticated administrators have a reachable call to unserialize in the Gdn_Format class.
Affected products
- Vanilla Forums: before 2.5.5; from 2.6.0 before 2.6.2 — fixed in 2.5.5, 2.6.2
How to fix
Upgrade to a fixed version: Vanilla Forums 2.5.5, 2.6.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2018-19499 or the next vulnerability affects your stack